Support Article
Report displays incorrect result after Daylight saving
SA-105659
Summary
In a report definition, on passing 'Yesterday' as a filter condition, results do not display even when the results are present.
Error Messages
Not Applicable
Steps to Reproduce
- Create a report with two Filter conditions.
- Make the first filter condition as Start date is less than or equal to yesterday.
- Make the second filter condition as End date is greater than or equal to yesterday.
Root Cause
A software use or operation error.
The Operator time was located in the Europe timezone and the Daylight saving was enabled now.
Resolution
Here’s the explanation for the reported behavior:
For the Daylight saving, the time is reduced by one hour for the DateTime columns.
Published April 11, 2020 - Updated October 8, 2020
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