Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Report exported to Excel missing data in some columns

SA-12243

Summary



Report data when exported to excel, the export misses the last 3 columns but those columns do have data on the screen when looking at them.


In the Excel file:


Error Messages



Not Applicable.

Steps to Reproduce



1) Run Report: Cycle Time Detail Report.
2) Export to excel. Observe the missing columns.


Root Cause



The root cause of this problem is a defect in customer application code or rules.
The data values that are showing as "False" in the report viewer are actually null values in the database. They are showing as "False" in the report viewer because the control being used is pxCheckbox, which shows as false (unchecked) with a null value. So the export file is actually correct, and the viewer was showing misleading values.


Resolution



This issue is resolved through the following local-change:

Change the control referenced on the report field. e.g. use "Display Text" control for the column. This shows a blank text string for the null values, and makes the report viewer consistent with the exported Excel file.
Suggest Edit

Published February 19, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us