Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Report replaces Vietnamese characters with question mark (?)

SA-49417

Summary

On exporting a report to PDF, the report replaces Vietnamese characters with question mark (?).


Error Messages



Not Applicable.


Steps to Reproduce

  1. Log in to Manager portal
  2. Navigate to 'My reports'
  3. Create any new report and add columns that include Vietnamese values in it
  4. Run the report and generate a PDF


Root Cause



A software use or operation error.


Resolution

Perform the following local-change:
  1. Open the fonts directory at the server location where the node/jvm is running.
  2. In pyPDFSetttings (belonging to Pega-Reporting UI) make the below changes:
    - Set Param.pyPDFEmbedFont :"true"
    - Set Param.pyPDFFontsDirectory : "C:\\Windows\\Fonts"(example)

Published February 20, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us