Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Report results are not loaded in UI

KCP-725

Summary

Despite displaying the count of issues in the application, the User Interface (UI) landing page does not display the results after executing the report.

 

Error Messages

Tracer error:

Failed to find instance @baseclass.pzLPApplicationUIGuardrailsInnerTable of type Rule-HTML-Section

 

Steps to Reproduce

  1. Log in to Pega Platform.
  2. Launch Dev Studio.
  3. Navigate to Configure > Application > Quality > App Studio Compliance > User Interface.
  4. Select an application ruleset.
  5. Click Run Analysis.

 

Root Cause

A defect in Pegasystems' code or rules.

 The pxResults of D_pzGuardRailsToEvaluate data page is rendered classless. This leads to rule resolution issues and the sections load incorrectly.

 

Resolution

Perform the following local-change:

Set Pega-Engine datapage/newgenpages Dynamic System Setting (DSS) to true.

This is resolved in the following:

  • Pega Platform 8.4.4
  • Pega Platform 8.5
Suggest Edit

Published December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us