Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Reports Browser checkboxes are displayed as Read-only

SA-46836

Summary



When Reports browser is opened, it renders checkboxes with their 'Yes' values, instead of checkboxes.


Error Messages



Not Applicable


Steps to Reproduce



Launch portal and click on Reports from left pane.


Root Cause



An issue in the custom application code or rules:

The section is rendered read-only and hence the checkboxes are showing Yes, No values instead of rendering as checkboxes.

data-click markup event generated on Reports link is below. Highlighted Yes signifies Read-only.


[["showHarnessWrapper",["newDocument","Data-Portal","TestReportBrowser","","","pyDisplayHarness","Reports","","Yes","",":event","","068b64fc-e219-4c16-bb81-fc724a0935e4","",""]],["runScript",["removeScreenLayoutMask()"]]]

Resolution



Perform the following local-change:

In the navigation rule 'pyCaseManagerLinks' (Available rule) of application ruleset, for Reports category > 'Launch Harness' action > Set 'Read only' to "No".



After the above change, the checkboxes are rendered as expected:

Published April 12, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us