Support Article
RequestorLockException - Running Post Upgrade tools
SA-736
Summary
After performing upgrade from PRPC 5.5 to Pega 7.1.5, Pega admin has run into "Internal Server Error" on the UI while running the following post upgrade tools:
- Lock and Roll
- List of Dynamic selects with  
- List of sections with  
Error Messages
[8/25/14 12:30:00:390 CDT] 00000011 SystemOut O 2014-08-25 12:30:00,390 [ WebContainer : 12] [ ] [ ] [ ] (ngineinterface.service.HttpAPI) ERROR |127.0.0.1: com.pega.pegarules.pub.context.RequestorLockException
com.pega.pegarules.pub.context.RequestorLockException: Unable to synchronize on requestor H1FA3BBC1C4AA375146F1BB10106D0FE3 within 120 seconds: (thisThread = WebContainer : 12) (originally locked by = WebContainer : 5) (finally locked by = WebContainer : 0)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.getLockOnRequestor(PRSessionProviderImpl.java:1381)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:916)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:815)
at com.pega.pegarules.session.external.engineinterface.service.EngineAPI.processRequest(EngineAPI.java:348)
at com.pega.pegarules.session.internal.engineinterface.service.HttpAPI.invoke(HttpAPI.java:778)
at com.pega.pegarules.session.internal.engineinterface.etier.impl.EngineImpl._invokeEngine_privact(EngineImpl.java:312)
at com.pega.pegarules.session.internal.engineinterface.etier.impl.EngineImpl.invokeEngine(EngineImpl.java:263)
at com.pega.pegarules.session.internal.engineinterface.etier.ejb.EngineBean.invokeEngine(EngineBean.java:225)
at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:611)
....
at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)
at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)
at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)
at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
Root Cause
Root cause of the problem lies in Websphere plugin configuration causing a refresh on timeout before Pega finishes its backend processing.
Resolution
ServerIOTimeout parameter is set to a value of 60 on Websphere plugin.
As a result, timeout errors occur while running post upgrade tools.
Change the IOServerOutput=1800 to resolve the issue.
Published October 19, 2015 - Updated October 8, 2020
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