Support Article
Resolved case displayed in workbasket
SA-39266
Summary
A case that has been resolved is still displayed in the workbasket.
Error Messages
Not Applicable
Steps to Reproduce
1. Login to an Out of the box portal provided in Pega Customer Service for Communications.
2. Click on “My Workbaskets” tab and open a case.
3. After the case is resolved, Pega will automatically close the case and display the home page screen with the resolved case still showing in the workbasket.
Root Cause
When user processes the work object, the dashboard (worklist or workbasket) does not get refreshed and the status is not updated. This is because CPMDashboardWorkList is not refreshed.
Resolution
Perform the following local-change:
Using the refesh condition as "D_CPMPortalRecents.pxUpdateDateTime Changes'" on the required section/layout as shown below fixes the issue.
Published July 28, 2017 - Updated December 2, 2021
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