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Support Article

Resolved Interaction still includes Header with Timer

SA-17534

Summary



Developer is resolving the interaction and then opens it from My Cases or from Recent Work. The interaction is opening in a review harness, but still it shows Header with Timer Disclosure.

Error Messages



NO Error Messages.

Steps to Reproduce

  1. Create an interaction and resolve it.
  2. Open the interaction from my cases or from recent work. Observe that interaction is opened in review harness with timer running.

Root Cause



An issue in the custom application code or rules.
When user creates an interaction the header section “CPMInteractionHeader” is loaded and it contains the duration.
 
When user opens the same interaction after resolution from recent work, it opens in review harness and the section "CPMReviewInteractionWorkHeader" is displayed in review mode.

But, developer has customized the application and displaying CPMInteractionHeader section in review harness.


Resolution



Perform the following local-change:

Keep a visibility condition on dynamic layout of duration in CPMInteractionHeader section and display the timer, if the interaction status is not equal to Resolved-Completed.

To track the time taken to resolve the interaction, then one must add property “InteractionTime” to CPMInteractionHeader section.

Interaction property is available in the clipboard with default value as zero and as soon as the interaction is resolved, a declare expression is fired based on pyResolvedTimestamp and set the value of InteractionTime to @DateTimeDifference(.pxCreateDateTime, .pyResolvedTimestamp, "").
 

Published January 31, 2016 - Updated October 8, 2020

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