Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

REST and OAuth 2.0 for authentication

SA-456

Summary



When calling the pyGetOAuthResource activity for OAuth 2.0 client authentication an exception is produced: "Unable to open an instance using the given inputs." Is OAuth 2.0 supported by any Pega 7 release?

Error Messages



"Unable to open an instance using the given inputs."


Steps to Reproduce



1.Create OAuth Client instance
2.Create activity to call "Data-Admin-Security-OAuth-Client.pyGetOAuthResource"
3.Exception caught while running the above activity


Root Cause



The root cause of this problem is defect/misconfiguration in the PRPC operating environment. PRPC does not support OAuth 2.0.


Resolution



PRPC only supports OAuth 1.0 at the present time.

Published March 27, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us