Support Article

RTE no wrapping/off-screen when read-only with no toolbar

SA-29833

Summary



When a large image is pasted in to a Rich Text Editor embedded in to a Grid - the Read Only view (without toolbard) shows the image full size, however you cannot see the right hand side or scroll to reach it.  If a very long word is entered it doesn't wrap.

Error Messages



No error messages


Steps to Reproduce



1st way:
  1. configure a Rich text Editor to have no toolbar in read only mode (in Presentation tab) in a cell of a Grid
  2. enter this string into it 11111111111111111111111111111111111111111111111111111111111111111111111111111111111111... (a very long string of letter 1 with no spaces)
  3. switch to review harness


2nd way:

  1. configure a Rich text Editor to have no toolbar in read only mode (in Presentation tab) in a cell of a Grid
  2. enable the add images in the operations tab of the RTE.
  3. paste a very big image in to it
  4. switch to review harness


Root Cause



A defect in Pegasystems’ code or rules

Resolution



Perform the following local-change: Added the following CSS to userworkform to scale down the image in review and break the text.


.dataValueRead #rte-default .rteReadOnlyWithoutTB{
word-break: break-all;
white-space: pre-wrap;
}


div#rte-default .rteReadOnlyWithoutTB img {
max-height: 100%;
max-width: 100%;
width: auto;
height: auto;
}
 
 

Published November 1, 2016 - Updated November 6, 2016

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.