Support Article
Rule Application Product (RAP) import fails with an error
SA-67018
Summary
Rule Application Product (RAP) import fails with an error.
Error Messages
There are changes from another session. Replaced with latest Revision Data.
Steps to Reproduce
- Create an RAP file in Revision Management from Revision and save it to the File System.
- Import the RAP from the Revisions tab of Revision Management Landing Page in the Built-On Application (Application Name).
- Click the 'Import revision' button and select the RAP file saved in Step 1.
- Select 'Deploy for at least one user' and leave the default.
- Log out and relog in.
- Confirm the current operator access group refers to the correct application version.
- Confirm the Overlay Ruleset Version is at the top of the application version ruleset stack.
- Confirm the updated rule is in the Ruleset version.
- Activate Revision from the Revisions tab of the Revision Management Landing Page in the Built-On application. The error occurs. Confirm no other Operators are updated. Activate and Discard are still active.
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-47956.
Published November 29, 2018 - Updated December 2, 2021
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