Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Rule design view does not render in IE11 11.0.44 and Edge 40.x

SA-42503

Summary



Rule design view does not render anything on the browser, if one opens a rule in Pega Designer Studio on IE11 v11.0.44 (Released on July 11th) or an Edge browser (for example, section and flow rules).


Error Messages



Not Applicable


Steps to Reproduce



1. Login into Designer Studio on a IE11 v11.0.44 or an Edge browser.
2. Open a rule that has a Design view e.g. section.
3. Verify if it renders content on the browser.


Root Cause




The below styles/css are referenced in 'pzDesignViewInclude' section. When removed, rules load as expected.

<pega:include name="RulesSpaceStyles"/>

<pega:static type="style" app="webwb" path="css">
<pega:file name="pega_yui_container.css"/>
</pega:static> There are syntax errors in pega_yui_container.css and RulesSpace.css rules that are responsible for the reported issue.

Resolution



Refer to the below table to see which hotfix you need to apply:
Pega HFix
7.1.6 HFix-36704
7.1.7 HFix-36705
7.1.8 HFix-36706
7.1.9 HFix-36707
7.1.10 HFix-36708
7.2 HFix-36709
7.2.1 HFix-36710
7.2.2 HFix-36711
7.3 HFix-36712

Suggest Edit

Published August 26, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us