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Support Article

Rule index unavailable or incomplete with Pega 7.1.9

SA-28322

Summary



Attempting to index Work, Rules or Data fails or is incomplete with Pega 7.1.9.


Error Messages



Rule Index File Is Incomplete / Corrupted


Steps to Reproduce



Attempt to index Rules, Work or Data.


Root Cause



A defect in Pegasystems’ code or rules  

The following local change will allow indexing to complete.

Resolution



Perform the following local-change steps:
  1. Disable the FTSIncrementalIndexer agent using the Data-Agent_queue record.
  2. Stop all servers.
  3. Delete all rows from table pr_sys_queue_ftsindexer.
  4. Delete all files and sub-directories from the indexing directory (as designated from the Search Landing Page).
  5. Start the app server that is the indexing node (only this node).
  6. Log onto Designer Studio on the started node.
  7. Go to the Search Landing page, and kick off a full re-index for All Data (this should be the fastest to complete).
  8. After data indexing is complete, kick off full re-index for All Work.
  9. After work indexing is complete, kick off full re-index for All Rules.
  10.  After rule indexing is complete, update the Data-Agent-Queue record to re-enable the FTSIncremental Indexer. 
  11. Use SMA to confirm that this agent is running (it will take up to 10 minutes for the updated value in Data-Agent-Queue to get picked up by the MasterAgent – but do NOT attempt to manually start this agent queue from SMA).
  12. Start other app server nodes.

 

Published October 4, 2016 - Updated October 8, 2020

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