Support Article
Rule not found issue with PRPC 6.3 SP1
SA-27801
Summary
User encounters a rule not found error when running the claim flow.
Error Messages
com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance myWorkClass-Work-ICC.DependentQuestionFormat for non personal RSLH 89448537f7651804ddbf01bff7d69d12
Steps to Reproduce
Run the claim flow.
Root Cause
A defect or configuration issue in the operating environment. There are transient network errors occurring which cause the onchange/refresh to fail. The refresh passes a pre-activity which is based upon a data class, and not a work class. When the section refresh fails, the system automatically issues a call to reloadHarness, and this is shown on the call stack of the error:
com.pegarules.generated.activity.ra_action_reloadharness_e76071240d162e7ee0fcb342eed12dde.step4_circum0(ra_action_reloadharness_e76071240d162e7ee0fcb342eed12dde.java:589)
The ReloadHarness logic has no way to determine that the preactivity is associated with a Data class as opposed to the Work class, and so tries to find it in the Work class, and fails. However, the primary error is the one that results in the failure of the reloadSection.
There is a defect in IE which makes it susceptible to certain operations which seem to be associated with the form that contains the field triggering the onchange or refresh. This error does not occur when using Chrome or Firefox browsers, and also does not occur if not using HTTPS.
This low-level error has been observed thrown by wininet once after adding diagnostics: ERROR_WINHTTP_INCORRECT_HANDLE_STATE. This is status 12019, and the documentation online is vague about what causes it, and how to prevent it.
Resolution
Perform the following local-change step:
Add changes to userworkform to modify the existing asyncRequest method to add logic to intercept failed AJAX requests and retry the request (up to a max of 2 retries).
As the error seems to be transient, the first retry usually succeeds in performing the reloadSection.
These changes depend upon the exact hotfix version of pega_ui_doc.
When experiencing these transient errors, contact GCS support for a custom version of userworkform.
Published September 21, 2016 - Updated October 8, 2020
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