Support Article
Rule resolution does not retrieve rules from UIKit at runtime
KCP-343
Summary
Despite adding the UIKit on top of a custom application, the rule resolution retrieves rules from the custom application at runtime instead of the UIKit.
Error Messages
Not Applicable
Steps to Reproduce
- Create a new application.
- Add the UIKit application to the application hierarchy.
- Launch the Case Manager portal.
- Create a case (rules are fetched from the custom application instead of the UIKit).
Root Cause
In the rule resolution of the application at the client end, Theme-Cosmos is added on top of the UIKit. However, the common rule in both the rulesets is not retrieved from UIKit since it is unsupported.
Resolution
Perform the following local-change:
Keep the UI-Kit ruleset above the Theme-Cosmos ruleset.
Tags:
Published December 2, 2021
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