Support Article
Rule Search does not work
SA-102448
Summary
Rule Search does not work. Indexes display as incomplete with no content on the queues. Indexes continue to display as incomplete despite the recreation attempt. The issue occurs post upgrading to Pega 8.3.
Error Messages
Not Applicable
Steps to Reproduce
Unknown
Root Cause
A defect or configuration issue in the operating environment.
Resolution
Perform the following local-change:
- Delete the below Dynamic System Settings (DSSs) which are not required for Pega 8.x version:
Pega-RULES • indexing/hostid
Pega-RULES • indexing/hostname
Pega-RULES • indexing/explicitindexdir
- Follow the below steps to make the index work:
a) Stop the server
b) Use the -Dindex.directory JVM argument to add the index directory (The index directory must be cleared or deleted or a fresh directory must be used)c) Keep a backup and truncate the PR_SYS_STATUSNODES tabled) Start the servere) Start the queue processorsf) Verify the Search landing page. If a re-index is happening, then, wait for some time or re-index rule, data and work
Published April 1, 2020 - Updated December 2, 2021
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