Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Rules are not getting tagged to a Ruleset Version

SA-7915

Summary



You have rules that show they are in a ruleset version in the rule configuration, but do not show up in the ruleset version report and are not exported when you create a product.

Error Messages



Not Applicable

Steps to Reproduce



1.  Create a “Coaching Tip Association," “Dialogs," or “Dialog Association” rule
2.  Run the Ruleset Version Report
3. Observe these rules are not in the report


Root Cause



The root cause of this problem is a defect in customer application code/rules. These rules are inserted into the database table pca_rule_assoc_ctip.  This table is supposed to have 3 database triggers on it which update the pr4_rule_vw table any time a rule is added/modified/deleted from the ctip table.  These triggers were missing.


Resolution



Add the missing triggers to the table.  Then execute the SQL statement 

update pca_rule_assoc_ctip set pzinskey=pzinskey;

to populate the pr4_rule_vw table.

Published January 31, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us