Support Article
Same case ID with multiple statuses in Workbasket
SA-21131
Summary
Two assignments in workbasket have same work ID.
Error Messages
Not Applicable
Steps to Reproduce
1. Create a flow. Route the assignment to workbasket: default@sae, and configure a local action that runs a flow using Call Work-.StartFlow.
2. Change the status of the assignment in the new flow, and route it to the same workbasket.
Root Cause
Whenever Work-.StartFlow is called, it starts a flow on work object. The new flow gets appended to pxFlow page as given below.
Since the FirstStep assignment and withdraw flow assignment are routed, two assignments with same work object ID is seen in the workbasket.
Resolution
Use Work-.New activity.
Published March 24, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.