Support Article

Same log file appears for nodes are opened in SMA

SA-26566

Summary



PegaRULES log file of Node 1 appears instead of the respective log files when other nodes are opened in System Management Application (SMA). The application was upgraded from PRPC 5.4 to Pega 7.1.8.

Error Messages



Not Applicable

Steps to Reproduce

  1. Open SMA.
  2. Click Node 1, and open PegaRULES log file under Logging and Tracing.
  3. Click on another node. Try to open PegaRULES log file under Logging and Tracing.

Root Cause



A defect or configuration issue in the operating environment:
SMA was configured incorrectly, hence nodes.xml file was empty.

Resolution



Use the temp directory dedicated for SMA. Refer to the PDN reference guide given below below for proper SMA configuration:
https://pdn.pega.com/documents/system-management-application-sma-54-sma-reference-guide

Published August 9, 2016 - Updated September 6, 2016

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.