Support Article
Same Work object is displaying multiple times in dash board
SA-28676
Summary
Same Work object is displaying multiple times in dash board and also present in Assign-Worklist with same work object reference.
Error Messages
Not applicable
Steps to Reproduce
- Open an assignment from the worklist which is pointed to a flow.
- Process the assignment such a way that, it now points to different flow.
- Close the work object without completing the flow.
- Reopen the same work object or assignment for the worklist. A screen would be shown that the following instance cannot be opened.
- Click Repair Assignment.
- Go back to the worklist on refresh two assignments with the same work object would be shown.
Root Cause
Flow is changing when user clicks on Cancel of the assignment and when trying to reopen the same work object.
But the updated assignment details are not present in the worklist.
As the list is not updated and the user is trying to access the old assignment which is pointing to a different flow which is currently not available, hence system is trying to creating a new one and we could see the two assignments pointing to different flow with same work object Id.
Resolution
Perform the following Local Change:
When we refresh the worklist it would be populated with the updated assignment.
To refresh the worklist a refresh condition is kept in the section of the worklist and workbasket. Any entry or removal of a document or work object is reflected in Declare_pzRecentCache.
So must be refreshed when the .pxUpdateDateTime of Declare_pzRecentCache is changed.
The below condition is imposed to refresh the worklist
Published October 21, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.