Support Article
Sample data for pega markets for FS is not available
SA-50774
Summary
Class PegaCRM-Data-Customer-FS is mapped to table mktdata.crmfs_customer in ExternalMKTData.
User reports that the table "crmfs_customer" is empty, and report definition doesn't return any records.
Error Messages
Use case : Pega collection.
In the sample application, when a collection case is created, an outbound call case should also be created.
At present, OC- case doesn't get created. On tracing the service activity we found the below soap response which shows "Customer Data Not Found"
Steps to Reproduce
1. Get the table mapped to the class "PegaCRM-Data-Customer-FS" through the class record "test connectivity" button.
2. Private edit the report definition "FetchContactDetails" of class "PegaCRM-Data-Customer-FS", present in "PegaCRMFS-Artifacts:07-31-01" ruleset, and remove the filter condition.
3. Run the report definition to get all of the records from the table. The report definition returns zero records.
4. Execute "select count(*) from mktdata.crmfs_customer" and get the count of records in the table. The count shows zero.
Root Cause
A defect in Pegasystems’ code or rules
Resolution
Primarily the activity StoreCustomerRecordsInDDS should be run if PegaMarketing for Financialservices is used.
For more details, refer to the document titled "Pega Marketing for Financial Services 7.31 Application Data Model" on PDN https://pdn.pega.com/products/pega-marketing-financial-services.
Published April 13, 2018 - Updated December 2, 2021
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