Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Save as for campaigns is not working correctly

SA-59952

Summary

On performing Save as of a campaign from another campaign, the modal dialog for the Save as does not close. After clicking the Close icon or Cancel button, the pop up closes and the screen refreshes to display the newly created campaign.


Error Messages



The following error were seen in the tracer:

[PegaMKT-Work-Program.pyMessageLabel]Planning Start cannot be past date
[PegaMKT-Work-Program.pyMessageLabel]PleaseEnterADate
[PegaMKT-Work-Program.pyMessageLabel]Planned Start Date cannot be past date



Steps to Reproduce

  1. Create a campaign
  2. Click Save as
  3. Give a unique name and click Submit. The campaign name field is blank
  4. Click the Close icon. The screen refreshes and the new campaign displays


Root Cause



An issue in the custom application code or rules.
The configuration of the campaign was incorrect with planning data set in the past.
​​​​
RESOLUTION


Perform the following local-change:

Change the planning start date to a future date.



 
Suggest Edit

Published September 20, 2018 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us