Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

"Save As" creates multiple instances of the same rule

SA-18714

Summary



Multiple instances of the same rule are being created in the database when performing a Save As and when importing a Product file multiple times.


Error Messages



Not Applicable.


Steps to Reproduce

Open a rule and perform a Save As to another ruleset version.
 

Root Cause

A defect or configuration issue in the operating environment. The rule tables did not have pzInsKey specified as the primary key.


Resolution



Make the following change to the operating environment:  

Remove the duplicate entries and add pzInsKey as the primary key.

Published October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us