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Support Article

Scheduled Base Segment Refresh functionality and batch job fails

SA-7198

Summary



Scheduled Base Segment Refresh functionality and Batch jobs fails.
Once the segment is checked out / In and refreshed page the issue is fixed.



Error Messages



2015-02-08 11:48:49,452 [ PegaRULES-Batch-3] [ STANDARD] [ PegaNBAM:06.03] (ccess.RDBListSpecificationImpl) ERROR - There is no table or class directive in the user SQL, and no class specified on the list page.

2015-02-08 11:48:49,452 [ PegaRULES-Batch-3] [ STANDARD] [ PegaNBAM:06.03] (port_Definition_Segment.Action) ERROR - PopulateSegmentTable: SQL Error ocurred whilst populating the segment PopulateSegmentTable: SQL error whilst populating segment: there is no table or class directive in the user SQL, and no class specified on the list page: code: <none> SQLState: <none> Message: <none>SQL = null

2015-02-08 11:48:49,457 [ PegaRULES-Batch-3] [ STANDARD] [ PegaNBAM:06.03] (port_Definition_Segment.Action) ERROR - Failure in processing segment: RefreshBaseSegment -


Steps to Reproduce



None.

Root Cause



The root cause of this problem is defect/misconfiguration in the PRPC operating environment.

Because the daily spine changes of customer records is getting delayed, a user is disabling the schedule of the segment by updating the rule and performing a checkout and checkin operation. This update forces the regeneration of the underlying report definition and on one occasion this report definition is not generated properly.The subsequent checkin and checkout rectified the problem with the report definition.



Resolution



To try and avoid any future re-occurence it is recommended to stop the SegmentSchedule agent to stop processing the scheduled segment items, in case there are delays to customer spine change.
 

Published January 31, 2016 - Updated December 2, 2021

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