Support Article
Scheduled Reports are not running and cannot be rescheduled
SA-32665
Summary
Scheduled reports are not running and resheduled. The scheduled tasks for the reports are listed as Completed on Reporting > Components > Scheduled Tasks landing page.
Error Messages
Not Applicable
Steps to Reproduce
Schedule a report.
Root Cause
A defect in Pegasystems’ code or rules: This deleted the queue item record from the database. When the report is rescheduled, there is no existing queue item record with pyAgentName populated. When the queue item is created, pyAgentName is not populated. Hence, the stored procedure, which should retrieve the queue item when it is due to run, fails.
Resolution
The reported issue is resolved in Pega 7.1.8 onward. Upgrade to Pega 7.1.8.
Published January 24, 2017 - Updated October 8, 2020
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