Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Scheduled reports go to completed state and stop running

SA-36346

Summary



Scheduled reports stop running on rescheduling.


Error Messages



Not Applicable


Steps to Reproduce

  1. Schedule a report
  2. Delete the schedule
  3. Reopen the report from the Recents list and reschedule it


Root Cause



A defect in Pegasystems’ code or rules: The wrong buttons are displayed on the Perform and Review harnesses when the scheduled report is reopened from the Recents list. When the rescheduled report is saved, entries in the pr_sys_queues table are corrupted, causing the pyAgentName to be null. This prevents the Scheduled Task Agent from retrieving the queue item record and executing the report at the scheduled time.

Resolution



Apply HFix-32408

Published April 24, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us