Support Article

Scheduled reports go to completed state and stop running

SA-36346

Summary



Scheduled reports stop running on rescheduling.


Error Messages



Not Applicable


Steps to Reproduce

  1. Schedule a report
  2. Delete the schedule
  3. Reopen the report from the Recents list and reschedule it


Root Cause



A defect in Pegasystems’ code or rules: The wrong buttons are displayed on the Perform and Review harnesses when the scheduled report is reopened from the Recents list. When the rescheduled report is saved, entries in the pr_sys_queues table are corrupted, causing the pyAgentName to be null. This prevents the Scheduled Task Agent from retrieving the queue item record and executing the report at the scheduled time.

Resolution



Apply HFix-32408

Published April 11, 2017 - Updated April 24, 2017

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