Support Article
Screen does not refresh on navigating back to parent case
SA-85560
Summary
User navigates back to a parent case from a child case on the Interaction portal. However, stale data of the parent case displays.
Error Messages
Not Applicable
Steps to Reproduce
- Configure a Service case which can have child cases and lists the child cases on it through a grid
- Configure a link that navigates back to the parent case assignment from the child case
- Launch a Service case that can have child cases
- Create two child cases
- Resolve the first child case
- Navigate back to the parent case and observe the state of the parent case
- Create another child case and navigate back to the parent case. The state reverts to the state before step 5
Root Cause
An issue in the custom application code or rules. Reload is not triggered on returning to the parent case.
Resolution
Perform the following local-change:
Select the Reload on every interaction option for the Open Assignment action that is configured on the link to navigate back to the parent case.
Published December 4, 2019 - Updated December 2, 2021
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