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Support Article

Screen hangs when Item is removed from basket

SA-39367

Summary



The screen hangs after removing item from basket in offer negotiation page with Pega Marketing for Communications 7.21 (PMC).

Adding one item form list to basket then go to the other tab and adding one item from the tab.

After that removing the previous item from the basket and as a result skin gets frozen.


Error Messages



Not Applicable


Steps to Reproduce



1. Navigate to offer negotiation.
2. Add one item from list to basket.
3. Go to the other tab and add one item from the tab.
4. Remove the item from the basket which is from the inactive tab, observe the portal freezes.


Root Cause



Due to developer customization for UI rules, default refresh timeout of 100 milli seconds is not sufficient in the OMFDeleteRowIconCtrl control.

Resolution



Perform a local change on OMFDeleteRowIconCtrl control to increase the refresh timeout >100 milliseconds.

Rule details

Rule Name : OMFDeleteRowIconCtrl
Ruleset: NBAFW 01-02-04
Line Number : 128
Suggested Change : var t = setTimeout(function() { if (b != null) { pega.util.Event.fireEvent(b,"onclick") } }, 700);

Published August 7, 2017 - Updated December 2, 2021

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