Support Article
Screens are not displayed in PEGA 7 during SSO login
SA-5664
Summary
When we login to application portal via SSO, some of the layouts(visible when conditions have been given) are not displayed. But they are displayed once either the screen is refreshed or the access role is changed from another to same one. This was working fine before upgrade from 6.2 SP2.
Error Messages
No error message, but required layout is not displayed.
Steps to Reproduce
Have layouts in section with visible when condition. Visible when condition checks for the current requestor's access role/group.
Root Cause
The root cause of this problem is a defect in customer application code/rules.
1. The said visible-when conditions are based on property values of OperatorID page.
2. After logging in using SSO some properties of OperatorID page are not having any values hence the user is not able to see the expected UI.
3. After verifying the user's authentication activity it was found that they are using setSecurityProfile() method and a step to call activity InitialProfileSetup.
4. But as the user is using PRCustom authentication type, there is no need of using the above method and calling the above activity. Instead they need to return a valid Data-Admin-Operator-ID page to Pega API.
Resolution
This issue is resolved through the following local change:
Include a Propert-Set in the authentication activity to set param.pyOperPage to the page of class Data-Admin-Operator-ID which was used to construct a valid operator. For more details on setting values to param.pyOperPage, please see the documentation at https://pdn.pega.com/documents/authentication-in-pegarules-process-commander-v53.
Published January 31, 2016 - Updated October 8, 2020
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