Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Search functionality does not work for Delegated rules

SA-73850

Summary



The Search functionality does not work for Delegated rules in the Customer Service Interaction portal.


Error Messages



Not Applicable


Steps to Reproduce

  1. Delegate a few rules for an Interaction portal Required access group.
  2. Open the Delegated rules section from the Interaction portal.
  3. Input a string in the Search box.
  4. Press the Enter key. The system must filter the Delegated rules based on the input Search string.


Root Cause



A defect in Pegasystems’ code or rules.

The Customer Service portal's pyDisplayHarness is of the CPM-Portal class instead of the Data-Portal class. Hence, the pySearchText is empty on the pyDisplayHarness.



Resolution



Apply HFix-51186.


 

Published March 6, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us