Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Search functionality is not working

SA-19621

Summary



Search functionality is not working properly in development environment, when searching with 'old:(SearchWord)' it is working.


It has been observed that search agents are not shown in search landing page and searchworkindexer agent is stopped when checking from System Managemnt Application (SMA).


Error Messages



No Results found even there are some search result records.


Steps to Reproduce



Type <searchword> in the search textbox and press Enter.


Root Cause



Search indexes were corrupted, need to rebuild the same.

Resolution



Do re-index for the required classes(Rule-,Data-,work-) to update temp file and click on check button to find index file size.

Following is the reference link for re-Index:

https://pdn.pega.com/support-articles/queries-related-re-index-process-work-objects


 
Suggest Edit

Published March 23, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us