Support Article
Search functionality in Pega 7.1.7 upgrade does not work
SA-12512
Summary
After upgrading to Pega 7.1.7 / CPM 7.13 / CPM FS 7.13 from PRPC 6.3 SP1 / CPM 6.2, it is observed that certain features for customer search, that are operational in PRPC 6.3 platform are no more functional in Pega 7.1.7. In search screen, after having searched for a user and decide to search another user, uplifted application does not show new customer search result.
Error Messages
This action is not allowed as it is outside the current transaction.
Steps to Reproduce
Not Applicable.
Root Cause
The issue is due to stale transaction thrown by pyStaleTransaction activity invoked directly by the rule engine, whenever there is a stale transaction.
A transaction becomes stale, when there is a mismatch in a transaction id or a duplicate submission for the same transaction id is submitted. For example, when a user clicks on back and forward buttons in the browser, the transactions gets resubmitted and these things are handled out-of-the-box (OOTB) by the core engine and considered as stale transaction. It invokes the pyStaleTransaction activity, in which the above error message is set and displayed.
In Pega 7, there were improvements done to efficiently handle the transactions better than in older versions and hence users are seeing this issue in Pega 7.1.7 and not in PRPC 6.3.
Resolution
Perform the following steps in user’s application to resolve the issue:
1. Create Activity to finish the CAInteraction Driver assignment.
2. CallPerformCardNumberactivity.
3. Remove call back function in the else block of the code for the Search Button, window.location.href = wrapperactivity.toURL().
Published August 11, 2015 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.