Support Article
Search functionality stops working on canceling reindexing
Summary
The Search functionality stops working on canceling a reindexing process.
Error Messages
Not Applicable.
Steps to Reproduce
- Create an initial index containing only certain classes due to restrictions on the size and amount of time it would take to complete a full index
- Restart the nodes. A complete work reindex is initiated by the Pega engine
- Cancel the process. Search breaks and the developers must reindex the classes that were originally indexed before this occurred
Root Cause
By default, a search is performed on startup to find a dummy document. If the document is not found, a full reindex is triggered. The only way to generate that document is to complete a full reindex.
Resolution
Here's the explanation for the reported behavior:
Setting the Dynamic System Setting, autoNodeCleanUpAndReIndex, to false will avoid this behavior. As long as the nodes retain consistent NodeIDs and have graceful shutdowns, there should be no issues. It is possible that if an unexpected shutdown occurred, “quorum not met” exceptions could be experienced during indexing. If this occurs, shut down all the indexing host nodes and, remove their entries from the <data_schema>.pr_sys_statusnodes table, then restart them.
Published April 10, 2019 - Updated October 8, 2020
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