Support Article
Search index file directory does not display on clicking Submit
SA-76610
Summary
Error occurs on the Search landing page. After clicking the Submit button, the Search index host node ID and the Search index file directory do not display.
Error Messages
The Flow Action post-processing activity pzLPSearchManagerSaveDetailsWrapperActivity failed: java.lang.NoClassDefFoundError: org.elasticsearch.threadpool.ThreadPool (initialization failure) -:** java.lang.NoClassDefFoundError: org.elasticsearch.threadpool.ThreadPool (initialization failure)
Error in WebSphere Application Server (WAS) System Error logs:
Exception in thread "StartupTaskUtil INITIALIZE_SEARCH" java.lang.NoSuchMethodError: com/acdxy/common/util/concurrent/MoreExecutors.directExecutor()Ljava/util/concurrent/Executor; (loaded from pegajdbc://724979475:0/guava-15.0.jar by com.pega.pegarules.bootstrap.loader.PRAppLoader@405baf4d) called from class org.elasticsearch.threadpool.ThreadPool (loaded from pegajdbc://724979475:0/prelasticsearch-2.4.0.jar by com.pega.pegarules.bootstrap.loader.PRAppLoader@405baf4d)
Steps to Reproduce
Add a Search index host node ID using the Search Index landing page.
Root Cause
A defect or configuration issue in the operating environment.
Multiple versions of the Guava Library (15.0, 18.0, and 19.0) were stored in the Pega database. However, only Guava Library 19.0 was shipped with Pega.
Resolution
- Run the following query in the database:
update <rules schema>.pr_engineclasses set pzcodeset='your_customerCodeset' where pzjar like '%guava%' and pzcodeset='customer';
This prevents the older Guava library versions from being added to the classpath during startup.
- Restart the application server.
Published April 6, 2019 - Updated October 8, 2020
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