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Support Article

Search issue due to issues with work objects re-indexing

SA-2874

Summary



Search is not working and Re-Indexing is not taking place properly. User is trying to search the work objects in Case Manager portal and they are unable to see the work object in the search result. On restarting the SystemWorkIndexer, user has reported that Last Run Finish was blank.

Error Messages



NA

Steps to Reproduce



NA

Root Cause



User is trying to search the work objects in Case Manager portal and they are unable to see the work object in the search result. User has verified that work-objects exists. User is having multi-node environment, and the HostID of the indexing node is not matching with pxSystemNodeID in the clipboard of the indexing node.
 

Resolution



Update the HostID in the Search-Settings tab (Pega Button->System->Tools ->Search) to match with the pxSystemNodeID of the Search Node, perform Re-Index manually and restarting the agents (SystemPulse, SystemIndexer and SystemWorkIndexer) helps Search functionality work properly.
 
During investigations, it was observed that PR_SYS_WORKINDEXER_QUEUE table has 1.06 million records. Whenever the Node ID of the search node on the landing page is incorrect, the queue (PR_SYS_WORKINDEXER_QUEUE table) will get filled up, because only the search node can update the index with the changes happening since the full re-index. To make the SystemWorkIndexer agent to work properly below steps were carried out:
  1. Stop all activity on this system (all nodes connected to this RuleBase)
  2. Stop SystemWorkIndexer agent.
  3. Truncate the PR_SYS_WORKINDEXER_QUEUE table. (take a back-up of this table)
  4. Re-index Work items from the Search landing page.

Published January 31, 2016 - Updated October 8, 2020

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