Support Article
Search results do not populate when searching for work objects
SA-50759
Summary
In the Interaction portal, Search results do not populate when searching for a work object.
Error Messages
** Search request failed. Query: [( _instancename:DRT-966*^5 OR I-96* )], Index [WORK]
Steps to Reproduce
- Log in to the system and launch the Interaction portal.
- Search for any work object ID.
Root Cause
An issue in the custom application code or rules.
Work object classes were not present in the pzWorkTypes parameter of the pySearch page. As a result, the search failed for these classes and the error occurred because the Search query did not accept all the parameters.
Resolution
Perform the following local-change to disable the When condition.
- Add all the work object classes in the Application rule in the Cases & Data tab.
- Save as the CPMLoadAggregateApplication activity to the Application ruleset.
- Disable the When condition for the Call CPMAggregateParentApplication.
Published February 21, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.