Support Article
Searches with ':' do not work correctly
SA-80034
Summary
Searches with ':' do not work correctly. The search with ':' works when a search string contains the special character in double quotes. However, if the search string contains multiple words and the entire string is in quotes, the search result matching the complete string is returned.
For example,
If the search string is buy content, then the content matching buy or content is returned.
If the same string is in quotes such as “buy content”, then only the content that contains the phrase buy content is returned.
Error Messages
Not Applicable
Steps to Reproduce
Perform a search with ':' included in the search text.
Root Cause
According to the Elastic search, ':' is a reserved character. To use this character in a search, the query string must also include a leading backslash.
Resolution
Perform the following local-change:
Update KMSearchParamsExtn, a step which replaces the ':',
@replaceAll(Param.pySearchString,":","\\:")
Tags:
Published August 15, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.