Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Searches with ':' do not work correctly

SA-80034

Summary



Searches with ':' do not work correctly. The search with ':' works when a search string contains the special character in double quotes. However, if the search string contains multiple words and the entire string is in quotes, the search result matching the complete string is returned.

For example,

If the search string is buy content, then the content matching buy or content is returned.

If the same string is in quotes such as “buy content”, then only the content that contains the phrase buy content is returned.



Error Messages



Not Applicable


Steps to Reproduce



Perform a search with ':' included in the  search text.


Root Cause



According to the Elastic search, ':' is a reserved character. To use this character in a search, the query string must also include a leading backslash.


Resolution



Perform the following local-change:

Update KMSearchParamsExtn, a step which replaces the ':',

@replaceAll(Param.pySearchString,":","\\:")

Published August 15, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us