Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Section containing iFrame is not rendereding correctly

SA-33387

Summary



Section containing iFrame is not rendering as blank.


Error Messages



Not Applicable


Steps to Reproduce



1. Configure a section with iFrame.
2. Run the use-case and observe that blank screen is appearing in the UI.


Root Cause



New single document dynamic containers are created with iFrame mode disabled by default.

Legacy iFrame mode is still available,but must be enabled by clicking the Use Legacy iFrame mode check-box.

Resolution



Enable “Use legacy iFrame mode(not recommended)” option in layout properties of the dynamic container.


Selecting this option renders the portal with iframes.

These kind of portals are not supported for mobile and this is the main impact or reason, why it is not recommended as mentioned in the bracket near the option If you want your portal to render in mobiles, then they should not use this option, iFrame will render but with may face some issues.


Refer this link for details :
https://pdn.pega.com/sites/pdn.pega.com/files/help_v719/procomhelpmain.htm#rule-/rule-html-/common/commonlayoutdynamiccontainer.htm

Suggest Edit

Published February 20, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us