Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Security vulnerablilities occur on Pega Pharmacovigilance 7.14

KCP-232

Summary

Pega Pharmacovigilance 7.14 is installed on Pega 7.1.8.

Security vulnerablilities occur in the Rule-HTML-Section WORK-!SURVEYSCRIPTSREFRESH section.

 

Error Messages

Not Applicable

 

Steps to Reproduce

  1. Launch Designer Studio
  2. Navigate to Org&Security > Tools > Security > Rule Security Analyser
  3. Select the rulesets
  4. Run the wizard

 

Root Cause

A defect in Pegasystems’ code or rules. The out-of-the-box SurveyScriptsRefresh section rule of Adverse Event Case Processing (AECP) Inbound ruleset in Pharmacovigilance application contains the below code which is Cross-Site Scripting (XSS) vulnerabilities.  

......

tools.getParamValue("SurveyName");   tools.getParamValue("QuestionPageName");   tools.getParamValue("QuestionName");   tools.getParamValue("NavigationType");   tools.getParamValue("SectionToRefresh");   tools.getParamValue("TaskSectionReference");   tools.getParamValue("StreamName");

....

 

Resolution

Apply HFix-63619.

 

Suggest Edit

Published December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us