Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Segment Filter in the Marketing Strategy does not return results

SA-45415

Summary



A Marketing Campaign has real-time events Engagement enabled.

The requirement is to exclude a segment from the Campaign definition and include it in the Marketing Strategy. This provides data for monitoring when a particular user is not applicable for the campaign as the user is not present in the segment.

The strategy does not return results when using the Segment Filter component in the Marketing Strategy.



Error Messages



Not Applicable


Steps to Reproduce

  1. Create a sample Segment.
  2. Create a Marketing Strategy with a Segment Filter at the beginning. Test the Strategy with the User ID which exists in the Segment. The Strategy never passes the Segment Filter.


Root Cause



The pyDefault data transform cannot be used to populate the customer data for Segment filter component when performing the Test Run in the strategy.


Resolution



On the Customer class, use a data transform to populate the SegmentList PageList property to test strategies.



Published February 24, 2018 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us