Support Article
Segment RD fails to load within default query time-out value
SA-1552
Summary
Segmentation report definition associated to a NBAM Segment rule was not loading in Production environment. Similar segmentation report definitions were working without any issues in Development / Test environments.
Error Messages
** ** Retrieving the report data exceeded the limit of 30 seconds. Please try making the report more specific by further limiting which rows to include.
STEPS TO REPRODUCE
Click on "Show Customers" button on a Segment rule. This behaviour was replicable under load with large customer data set.
Root Cause
Query time-out setting (pyQueryTimeoutInterval) was set to 30 seconds. This time-out value was not sufficient to populate the segmentation report in issue reported environment.
Resolution
Increase query time-out setting (pyQueryTimeoutInterval) to a higher value (say 60 seconds) has helped resolve the reported issue.
Tags:
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.