Support Article
Segment Schedule doesn't work
SA-1633
Summary
i have segments OTYHANDSETCUSTOMERS and OTYEXCLPLAN, both set up to refresh daily (every weekday or every 1 day) and the refresh doesn't occur.
The SegmentSchedule Agent is on.
---------------------------------------
Oracle 11.2.
JBoss AS 5; EAP 5.1
- Is the schedule failing to be scheduled and run every day or only certain days or on random days?
The segments should refresh daily and it has never happened since createing the schedule.
- Is this issue occurring for all segments? both newly created ones and pre-existing ones (if any)?
For all segments that have a schedule, both newly created and pre-existing.
- Was this schedule running successfully after being created and now it is no longer running?
Last week was the first time i scheduled a segment refresh on PPD DEV. The segments had been created earlier this year without a refresh schedule.
Segment OTYEXCLPLANS has a schedule starting with the 26th August and was never refreshed automatically once.
Segment OTYHANDSETCUSTOMERS has a schedule starting with 30 August and it seems that on the starting day it was run, but not yesterday.
Both segments have a daily refresh schedule: OTYEXCLPLANS at 10:20 GMT+2, OTYHANDSETCUSTOMERS at 11:00 GMT+2
Error Messages
None
Steps to Reproduce
Set up a segment with a schedule and follow up to see if it refreshes as scheduled.
Root Cause
The root cause of this problem is defect/misconfiguration in the PRPC operating environment.
Due Segment issues raised in SR-117055, the schedule get broken and placed in broken queue, this needs to be manually requeued to put the schedule back on.
Resolution
Requeued the broken queue item after resolving the segment execution problems.
Tags:
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.