Support Article
SendDTMF behavior incorrect
SA-18626
Summary
DTMF is being sent to the wrong Line.
User is on Customer Process Manager (CPM) 7.1.3 on Pega 7.1.8
Deployment scenario:
Agent 1 is on Line 1 with customer. Agent 1 attempts to warm transfer to Agent 2 who's line 1 is occupied.
Agent 2 declines the call sending the call to voicemail. When Agent 1 attempts to navigate Agent 2's Voicemail IVR, DTMF tones are sent to Agent 1's Line 1 (user) instead of Line 2 (VM).
Error Messages
No error messages.
Steps to Reproduce
- When on line with a client, attempt a warm transfer to a second Agent. The second agent declines the call, sending it to voicemail.
- Navigate to the voicemail menu tree.
- DTMF tones are sent to client on Line 1, not voicemail on Line 2.
Root Cause
A defect in Pegasystems’ code or rules: PegaCall fails to detect which line is active to send the DTMF.
Resolution
Apply HFix-25096.
Published January 31, 2016 - Updated October 8, 2020
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