Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Service agent does not pick items from the service queue

SA-62473

Summary



Service agent does not pick items from the service queue.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Send an asynchronous response from an external system through Service-HTTP
  2. Lock the work objectThe service activity queues the response to the Service Queue, System-Queue-ExecutionRequest-Service-Default
  3. Release the work object lock
  4. Wait for a minimum of 5 minutes
  5. Check if the item was picked and processed from the queueThe items continue to remain in the queue and after all the attempts moves to the broken queue which is not the expected behavior


Root Cause



A defect in Pegasystems’ code or rules. The service activity does not process correctly in the queue XML. It displays the Database Roll back exception every time instead of the actual exception.


Resolution

Apply HFix-43793.


 

Published January 30, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us