Support Article
Service agent does not pick items from the service queue
SA-62473
Summary
Service agent does not pick items from the service queue.
Error Messages
Not Applicable.
Steps to Reproduce
- Send an asynchronous response from an external system through Service-HTTP
- Lock the work object. The service activity queues the response to the Service Queue, System-Queue-ExecutionRequest-Service-Default
- Release the work object lock
- Wait for a minimum of 5 minutes
- Check if the item was picked and processed from the queue. The items continue to remain in the queue and after all the attempts moves to the broken queue which is not the expected behavior
Root Cause
A defect in Pegasystems’ code or rules. The service activity does not process correctly in the queue XML. It displays the Database Roll back exception every time instead of the actual exception.
Resolution
Apply HFix-43793.
Published January 30, 2019 - Updated October 8, 2020
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