Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Service Level Agreements (SLAs) processing slowness

SA-1270

Summary



SLA processing is slow.
 
The following behavior has been reported:

-The system adds approximately 10,000 SLA queue records to the queue table for normal end-of-day assignment processing.

-It takes an excessively long time (four and a half hours) for PRPC to complete the processing of these records.

Error Messages



NA



Root Cause



Reviewed PegaRULES ALERT log files and noticed that the queries under the sppr_sys_reservequeueitem_b stored procedure are a bottleneck with each run of the stored proc consuming ~15 seconds at an average.

Resolution



Pega DBAs recommend adding the following database indices to Pega ‘queue’ tables to optimize performance of SPPR_SYS_RESERVEQUEUEITEM_B in production.create index queue_reserve on pr_sys_queues (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queuesla_reserve on pr_sys_queue_sla (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queuesvc_reserve on pr_sys_queue_execreq_svc (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queueconn_reserve on pr_sys_queue_execreq_conn (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queuesla_update on pr_sys_queue_sla (pyItemId ASC, pyItemStatus ASC);       
 
The abovementioned bottleneck observed in sppr_sys_reservequeueitem_b was resolved after addition of the recommended DB indices.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us