Support Article
Session timeout when viewing history records
SA-8975
Summary
Session timeout occurs when you, as an application developer, pull data from PC_HISTORY_WORK table.
As a result, users face time out issues when viewing history records.
Error Messages
Service Unavailable
Steps to Reproduce
Pull data from PC_HISTORY_WORK table from application side.
Root Cause
The table PC_HISTORY_WORK from which the records are being fetched does not have indexes.
Resolution
This issue is resolved by making the following change to the operating environment:
1. Build indexes on the columns in the table which are used to fetch the records.
2. Archive the table regularly to limit the size of the current table.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.