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Support Article

Severe Performance issue on Bringing the agent up

SA-31599

Summary



Whenever user tries to bring the Agent up, the server performance goes down and the server goes into a hang status.
 

Error Messages



Caused by SQL Problems. Problem #1, SQLState null, Error code 0: com.ibm.websphere.ce.cm.ConnectionWaitTimeoutException:  ABC_PQR_XYZ09990 at com.pega.pegarules.data.internal.access.ExceptionInformation.createExceptionDueToDBFailure(ExceptionInformation.java:163) at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.getConnection(ConnectionManagerImpl.java:1362) at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.getConnection(ConnectionManagerImpl.java:977) at com.pega.pegarules.data.internal.access.ThreadConnectionStoreImpl.getConnection(ThreadConnectionStoreImpl.java:389) at com.pega.pegarules.data.internal.access.RDBPageResultPackager.getConnection(RDBPageResultPackager.java:924) at com.pega.pegarules.data.internal.access.DatabaseImpl.list(DatabaseImpl.java:5873) at com.pega.pegarules.data.internal.access.DatabaseImpl.executeRDB(DatabaseImpl.java:6461) at com.pega.pegarules.data.internal.access.DatabaseImpl.executeRDB(DatabaseImpl.java:6422) at com.pega.pegarules.data.internal.access.DatabaseImpl.executeRDB(DatabaseImpl.java:6403) at com.pega.pegarules.session.internal.authorization.context.GlobalContextCache.doesTopAppHashNeedToBeInsertedIntoFlattenedHierarchy(GlobalContextCache.java:1487) ... 44 more Caused by: com.ibm.websphere.ce.cm.ConnectionWaitTimeoutException: ABC_PQR_XYZ at com.ibm.ws.rsadapter.AdapterUtil.toSQLException(AdapterUtil.java:1680) at com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource.getConnection(WSJdbcDataSource.java:661) at com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource.getConnection(WSJdbcDataSource.java:611) at com.pega.pegarules.data.internal.access.DataSourceManager.getConnection(DataSourceManager.java:321) at com.pega.pegarules.data.internal.access.DatabaseConnectionImpl.activate(DatabaseConnectionImpl.java:1350) at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.getConnection(ConnectionManagerImpl.java:1312) 


Steps to Reproduce



Turn on the agent and check the performance after two hours.


Root Cause



Due to unavailability of connections when agent is running.

Resolution



Increase the maximum number of connections based on number of users are try to hit the server.
It is recommended to validate the connections  by enabling the  'Validate connections' option under 'WebSphere Application Server data source properties'.
 

 

Published January 2, 2017 - Updated October 8, 2020

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