Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Show BAN or Show Customers report times out

SA-70683

Summary



Report times out on running the out-of-the-box Show BAN or Show Customer report containing a large number of results. This occurs when the report retrieves the total result count to present the paging gadget. The issue persists despite installing HFix-44305.


Error Messages



Not Applicable


Steps to Reproduce



Click the Show Customer or Show BAN action in Pega Marketing.


Root Cause



HFix-44305 provided an option on the Report Viewer tab, of the report definition rule, to disable the retrieval of the Total Result count and default to the 'Next Previous' style of Paging control. However, Pega Marketing did not use the Report Viewer and instead, used an alternate presentation that did not fetch the Report Viewer's paging options. The requirement was for Pega Marketing Report Presentation to retrieve the Report Viewer paging options.
Since Pega Marketing did not fetch the Report Viewer's paging options, the total result count was always retrieved. For large result sets, the report timed out.


Resolution



Apply the following hotfixes:
  1. HFix-49113
  2. HFix-48933

 

Published March 19, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us