Support Article
SLA agent fails due to RuleNotFoundException
SA-66212
Summary
An assignment is configured with a Service Level Agreement (SLA) that invokes an Escalation activity to complete the assignment. Intermittently, the SLA agent fails when processing the queue items.
Error Messages
Flow <FlowName> had an error in step Utility5:
com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance <ClassName>.<ActivityName> for non personal RSLH 5004c59f74192a820954e3b9ae0d5f7d Top App Hash PegaRULES!en_US_!PRPC:Agents!06.03$2ee6c141136e77e062a1187848bbb670 of type Rule-Obj-Activity.
Trying to save an invalid page: page is not valid
Steps to Reproduce
Unknown
Root Cause
In this case, a commitwitherrorhandling step in the application activity could cause the SLA agent to lose the context.
A similar error was reported in this Support Article: https://community.pega.com/support/support-articles/agent-not-able-find-rule-while-sla-escalation-activity-execution
Resolution
As a local-change, delete the Commit step.
Tags:
Published November 29, 2018 - Updated December 2, 2021
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