Support Article
SLA Broken-Process when using 'Refer to a data page' on a pag...
KCP-341
Summary
On locking a parent case, a Lock error occurs when the ServiceLevelEvents agent processes a queue item for a child case. As a result of the error, the queue item immediately navigates to the Broken-Process status, instead of re-queuing the item to re-try in 15 minutes. The issue occurs when a page list property is configured with the 'Refer to a data page' option.
Error Messages
Cannot obtain a lock on instance ORG-SAMPLE-WORK 5000802, as Requestor BX9YXGV2IT25EHCP2TOGSW60N6BFL2HCJA already has the lock
Steps to Reproduce
- Create a page list property with 'Refer to a data page' selected and retain the property as a part of a case.
- Create a flow with a Service Level Agreement (SLA) for immediate processing.
- Lock the case before the ServiceLevelEvents agent processes the queue item.
ROOT CAUSE
A defect in Pegasystems’ code or rules.
Resolution
This feature is implemented in Pega Platform 8.1.9.
Published December 2, 2021
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